The very latest Adobe Acrobat Reader 9.3.4 (as of today 10th September 2010) is vulnerable (plus earlier versions) to this cooltype sing exploit. No fix as yet.